Uploaded image for project: 'Policy Framework'
  1. Policy Framework
  2. POLICY-2538

API component should deal with missing "type_version when creating a policy

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: Frankfurt Release
    • Fix Version/s: Frankfurt Release
    • Component/s: None
    • Labels:

      Description

      Policy creation API with a missing "type_version" are successful, but policies cannot be retrieved with GET requests.    In addition, these policies cannot be deployed neither, PAP shows NullPointerExceptions trying to deploy it.

      API should either reject such requests, or should populate type_version accordingly to be used by downstream components.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            liamfallon Liam Fallon
            Reporter:
            jhh Jorge Hernandez
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: