Uploaded image for project: 'Multicloud'
  1. Multicloud
  2. MULTICLOUD-1073

multicloud-k8s jobs are failing - docker client version too new

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • High
    • Resolution: Done
    • Frankfurt Release
    • None
    • None

    Description

      Seems like multiple gerrits for multicloud-k8s are failing now.  One common failure is in the multicloud-k8s-master-kud-deployment-verify-shell job.

      A couple example gerrits with this issue are:

      https://gerrit.onap.org/r/c/multicloud/k8s/+/107497

      https://gerrit.onap.org/r/c/multicloud/k8s/+/107922

      The error seen in the log is:

      RUNNING HANDLER [container-engine/docker : Docker | wait for docker] ***********
      Wednesday 20 May 2020 04:07:45 +0000 (0:00:02.748) 0:01:35.321 *********
      FAILED - RETRYING: Docker | wait for docker (20 retries left).
      FAILED - RETRYING: Docker | wait for docker (19 retries left).
      <snip a few out>

      FAILED - RETRYING: Docker | wait for docker (1 retries left).
      fatal: [localhost]: FAILED! => {"attempts": 20, "changed": true, "cmd": ["/usr/bin/docker", "images"], "delta": "0:00:00.057067", "end": "2020-05-20 04:08:09.455528", "msg": "non-zero return code", "rc": 1, "start": "2020-05-20 04:08:09.398461", "stderr": "Error response from daemon: client version 1.40 is too new. Maximum supported API version is 1.39", "stderr_lines": ["Error response from daemon: client version 1.40 is too new. Maximum supported API version is 1.39"], "stdout": "", "stdout_lines": []}

      Attachments

        # Subject Branch Project Status CR V

        Activity

          People

            ritusood Ritu Sood
            ewmulta Eric Multanen
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: