Uploaded image for project: 'Multicloud'
  1. Multicloud
  2. MULTICLOUD-702

Upgrading python2 to python3 for openstack plugin

    XMLWordPrintable

Details

    Description

      upgrade python2 to python3

      Upgrading Django from version 1.9.6 to 2.2.3 because of security issue [1].

      Bin Yang passed on the message from the TSC meeting that we need to fix [1] in E release, otherwise, we won’t be able to publish the Plugin.

      The last version to support Python 2.7 is Django 1.11 LTS, so we must upgrade Python2 to Python3.

       

      Bin said this is a top priority. He let me fix it for Ocata, Pike and StarlingX plug-in. Other plug-ins are responsible for other plug-in owners.

      If we don’t fix [1] for Ocata, Pike and  StarlingX plug-in, those plug-ins will be deleted. we also can’t submit pluggable function.

       

      [1] security issue image which can be found in the attachment.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          People

            haibin Huang Haibin
            haibin Huang Haibin
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: